メインコンテンツへスキップ

Excelで対角行列を抽出する方法は?

ワークシートに次のデータがあり、スクリーンショットに示すように、データ範囲から対角行列の値を抽出する必要があるとします。 Excelのマトリックスから対角線上に値を抽出しようとしたことがありますか?

doc-extract-diagonal-1

数式を使用してExcelで対角行列を抽出します


矢印青い右バブル 数式を使用してExcelで対角行列を抽出します

マトリックス範囲から対角線上に値を取得するのに役立つ簡単な数式を次に示します。次のようにしてください。

1。 データの横の空白のセルに、次の数式を入力してください。 = INDEX(A1:E1、、ROWS($ 1:1))、スクリーンショットを参照してください:

doc-extract-diagonal-1

2。 次に、エラー値が表示されるまで、フィルハンドルを範囲までドラッグします。 また、対角行列の値は、左上から右下に次のように抽出されています。

doc-extract-diagonal-1

3。 最後に、必要に応じてエラー値を削除できます。

注意:

1.議論 A1:E1 対角セル値を抽出する最初の行範囲です。必要に応じて変更できます。

2.この数式は、5列と5行など、同じ列番号と行番号を持つ範囲セルにのみ適用できます。


関連記事:

Excelで範囲の対角線を合計する方法は?

最高のオフィス生産性向上ツール

人気の機能: 重複を検索、強調表示、または識別する   |  空白行を削除する   |  データを失わずに列またはセルを結合する   |   数式なしのラウンド ...
スーパールックアップ: 複数の基準の VLookup    複数の値の VLookup  |   複数のシートにわたる VLookup   |   ファジールックアップ ....
詳細ドロップダウン リスト: ドロップダウンリストを素早く作成する   |  依存関係のドロップダウン リスト   |  複数選択のドロップダウンリスト ....
列マネージャー: 特定の数の列を追加する  |  列の移動  |  Toggle 非表示列の表示ステータス  |  範囲と列の比較 ...
注目の機能: グリッドフォーカス   |  デザインビュー   |   ビッグフォーミュラバー    ワークブックとシートマネージャー   |  リソースライブラリ (自動テキスト)   |  日付ピッカー   |  ワークシートを組み合わせる   |  セルの暗号化/復号化    リストごとにメールを送信する   |  スーパーフィルター   |   特殊フィルター (太字/斜体/取り消し線をフィルター...) ...
上位 15 のツールセット12 テキスト 工具 (テキストを追加, 文字を削除する、...)   |   50+ チャート 種類 (ガントチャート、...)   |   40+ 実用的 (誕生日に基づいて年齢を計算する、...)   |   19 挿入 工具 (QRコードを挿入, パスから画像を挿入、...)   |   12 変換 工具 (数字から言葉へ, 通貨の換算、...)   |   7 マージ&スプリット 工具 (高度な結合行, 分割セル、...)   |   ... もっと

Kutools for Excel で Excel スキルを強化し、これまでにない効率を体験してください。 Kutools for Excelは、生産性を向上させ、時間を節約するための300以上の高度な機能を提供します。  最も必要な機能を入手するにはここをクリックしてください...

kteタブ201905


Officeタブは、タブ付きのインターフェイスをOfficeにもたらし、作​​業をはるかに簡単にします

  • Word、Excel、PowerPointでタブ付きの編集と読み取りを有効にする、パブリッシャー、アクセス、Visioおよびプロジェクト。
  • 新しいウィンドウではなく、同じウィンドウの新しいタブで複数のドキュメントを開いて作成します。
  • 生産性を 50% 向上させ、毎日何百回もマウス クリックを減らすことができます!
Comments (3)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
buongiorno, purtroppo sto cercando di usare la formula di somma in diagonale da basso a sinistra ad alto a destra

=SOMMA($D$12:F14*((RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF.COLONNA($D$12:F14)))

in un excel in italiano... la formula però mi restituisce 0 ... è come se non verificasse mai la condizione (RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF.COLONNA($D$12:F14) come positiva
This comment was minimized by the moderator on the site
Hi.please teach us how to do the process inverse.
This comment was minimized by the moderator on the site
Thanks it help! i like it
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations