Note: The other languages of the website are Google-translated. Back to English

Excelで範囲内の単位と数値を正しく合計するにはどうすればよいですか?

以下のスクリーンショットに示すように、各果物の輸入量に関するデータの範囲があり、この範囲の単位で数値を合計するとします。 一般に、数式= SUM(range)は数値と単位を正しく合計できませんが、このチュートリアルでは、Excelでこの計算をすばやく解決するための優れた方法を紹介します。

単位1のドキュメント合計番号

数式による単位で数値を合計する

Excel用のKutoolsによる単位で数値を合計する良いアイデア3

Kutools forExcelと同じ単位に基づく合計数

重複する行を結合し、対応する数値をKutools forExcelで合計します 良いアイデア3


数式による単位で数値を合計する

Excelでは、数式を使用してこのタスクを処理できます。

空白のセルを選択し、この数式を入力します = SUM(SUBSTITUTE(B2:B7、 "kg"、 "")+ 0) それに、そして押します Shift + Ctrl + Enter 正しい結果を得るために同時にキーを押します。

単位2のドキュメント合計番号
ドキュメント矢印
単位3のドキュメント合計番号

ヒント: 上記の式で、B2:B7は合計する単位の数値、kgはデータ範囲の単位、すべての数値は同じ単位である必要があります。


Excel用のKutoolsによる単位で数値を合計する

覚えにくいために長い数式を適用してこのジョブを解決したくない場合は、を適用することで、数字だけでなくすべての文字を削除することができます Kutools for Excel 's 文字を削除する 効用を計算し、簡単な式で合計します。

Kutools for Excel, 以上で 300 便利な機能は、あなたの仕事をより簡単にします。 

後の 無料インストール Kutools for Excel、以下のようにしてください:

1.単位と連結されている番号を選択し、をクリックします クツール > テキスト > 文字を削除する。 スクリーンショットを参照してください:

単位13のドキュメント合計番号

2.次に確認します 非数値 オプションのみ 文字を削除する ダイアログ。 スクリーンショットを参照してください:

単位5のドキュメント合計番号

3。 クリック Ok or お申し込み、および選択したセルの数値のみが保持されます。 次に、空白のセルを選択してこれを入力します = SUM(B2:B7) 結果を計算する式。 スクリーンショットを参照してください:

単位6のドキュメント合計番号
ドキュメント矢印
単位7のドキュメント合計番号

Kutools forExcelと同じ単位に基づく合計数

以下のスクリーンショットに示すように、果物、数字、およびさまざまな単位が含まれているテーブルがある場合、11 Kg + 7 Kg、9ポンド+ 11ポンドなど、同じ単位に基づいて数字を合計するにはどうすればよいですか。
単位8のドキュメント合計番号

後の 無料インストール Kutools for Excel、以下のようにしてください:

1.合計結果を配置するセルを選択し、をクリックします クツール > フォーミュラヘルパー > 統計的 > 同じテキストに基づく合計.
単位8のドキュメント合計番号

2。 の中に 数式ヘルパー ダイアログ、に移動 引数入力 セクションで、数値と単位を含む範囲を選択します レンジ テキストボックスで、単位テキストを選択するか、合計する単位テキストを入力します。 テキスト テキストボックス。 クリック Ok.
単位8のドキュメント合計番号

先端:デフォルトでは、セル参照は[引数]入力セクションに絶対として表示されます。自動入力ハンドルで数式を適用する必要がある場合は、相対に変更してください。

次に、最初の合計結果が取得されました。
単位8のドキュメント合計番号


重複する行を結合し、対応する数値をKutools forExcelで合計します

ただし、以下のスクリーンショットに示すように、データ範囲に複数の単位が含まれていて、同じ単位で数値を合計したい場合は、この場合、次を使用することもできます。 高度な結合行 の機能 Kutools for Excel 解決する。

単位8のドキュメント合計番号

後の 無料インストール Kutools for Excel、以下のようにしてください:

1.データ範囲を選択し、をクリックします クツール > マージ&スプリット > 高度な結合行。 スクリーンショットを参照してください:

単位14のドキュメント合計番号

2。 の中に 列に基づいて行を組み合わせる ダイアログで、 ユニット 列とクリック 主キー 主キーとしてマークします。 スクリーンショットを参照してください:

単位10のドキュメント合計番号

3.次に、 重量 数字を含む列をクリックして 計算 > 合計。 スクリーンショットを参照してください:

単位11のドキュメント合計番号

4。 クリック Ok そして今、同じ単位が合計されます。

単位12のドキュメント合計番号


関連記事:


最高のオフィス生産性ツール

Kutools for Excelはほとんどの問題を解決し、生産性を80%向上させます

  • 再利用: すばやく挿入 複雑な数式、チャート および以前に使用したものすべて。 セルを暗号化する パスワード付き。 メーリングリストを作成する そしてメールを送る...
  • スーパーフォーミュラバー (複数行のテキストと数式を簡単に編集できます); 読書レイアウト (多数のセルを簡単に読み取って編集する); フィルター範囲に貼り付け...
  • セル/行/列をマージする データを失うことなく; 分割セルコンテンツ; 重複する行/列を組み合わせる...重複セルを防止します。 範囲を比較する...
  • [複製]または[一意]を選択します 行; 空白行を選択 (すべてのセルは空です); スーパーファインドとファジーファインド 多くのワークブックで; ランダム選択...
  • 正確なコピー 数式参照を変更せずに複数のセル。 参照の自動作成 複数のシートに; 箇条書きを挿入、チェックボックスなど...
  • テキストを抽出、テキストの追加、位置による削除、 スペースを削除する; ページング小計の作成と印刷。 セルの内容とコメントを変換する...
  • スーパーフィルター (フィルタースキームを保存して他のシートに適用します); 高度な並べ替え 月/週/日、頻度など。 特殊フィルター 太字、斜体...
  • ワークブックとワークシートを組み合わせる; キー列に基づいてテーブルをマージします。 データを複数のシートに分割; xls、xlsx、PDFをバッチ変換...
  • 300 以上の強力な機能. Office / Excel 2007-2021 および 365 をサポートします。すべての言語をサポートします。 企業や組織に簡単に導入できます。 フル機能の 30 日間無料トライアル。 60日間の返金保証。
kteタブ201905

Officeタブは、タブ付きのインターフェイスをOfficeにもたらし、作​​業をはるかに簡単にします

  • Word、Excel、PowerPointでタブ付きの編集と読み取りを有効にする、パブリッシャー、アクセス、Visioおよびプロジェクト。
  • 新しいウィンドウではなく、同じウィンドウの新しいタブで複数のドキュメントを開いて作成します。
  • 生産性を 50% 向上させ、毎日何百回もマウス クリックを減らすことができます!
officetab下部
コメントを並べ替える
コメント (1)
まだ評価はありません。 最初に評価してください!
このコメントは、サイトのモデレーターによって最小化されました
Bonjour dans le tout 1er exercice、ce n'est pas "= SOMME(SUBSTITUT(B2:B7、" kg "、" ")+ 0)" mais "= SOMME(SUBSTITUE(B2:B7;" kg ";" " )+0)"。 Il faut mettre des points virgules sinonmessaged'erreur。 Merci beaucoup pour ce tuto ilm'abeaucoupaidé。
ここにはまだコメントが投稿されていません

フォローする

著作権©の2009 - WWW。extendoffice.com。 | | 全著作権所有。 搭載 ExtendOffice。 | サイトマップ
MicrosoftおよびOfficeのロゴは、米国MicrosoftCorporationの米国およびその他の国における商標または登録商標です。
SectigoSSLで保護